Grade wollte ich Daten von meinem BookPro auf den MacPro ziehen und wundere mich, dass ich mich nicht mit ihm verbinden konnte. Der Rechner wurde zwar angezeigt, aber als ich mich als User einloggen wollte, um mich mit dem Ordner zu verbinden, wurde kein Volume zum Auswählen angezeigt. Nunja, ich dachte, ich schieb es mal auf Leo und habe die Kiste neu gebootet.

Denkste! Der MacPro bootet seit dem nimmer!!

Wenn ich ihn einschalte, kommt der Boot-Sound, und das Apple-Logo wird angezeigt… darunter dreht sich auch das Rädchen…. allerdings dreht es sich jetzt schon seit 12 Minuten… Also hab ich den Rechner ausgeschaltet und per APFEL + V gebootet, damit ich sehen kann, an welcher Stelle er hängen bleibt.

Und hier bleibt stehen:

com.apple.launchd[1] (com.apple.mDNSResponder[16]); posix_spawnp("/usr/sbin/mDNSRsponder", ...): No such file or directory

…und da zählt er hoch… die Zahl, die ich s.o. mit 16 angegeben hab wird dabei immer um einen erhöht.

Daraufhin habe ich den Rechner im Target-Mode gestartet (T beim Booten gedrückt halten) und per FireWire an mein Book angeschlossen. Die MacPro-Platte wird so auf dem Book gemountet.

Nun kann man sich per Terminal auf dem Book die Platte ansehen: cd /Volumes/PLATTE

Dort habe ich in /usr/sbin/ dann auch den mDNSRsponder-Daemon gefunden, der angeblich “no such file” ist. Daran konnte es also nicht liegen.

Ich wechsle also zurück ins /Volume-Verzeichnis, tippe dort mal ls -la ein und bekomme folgende Rechte für die MacPro-Platte angezeigt: drwxrwx--- !!!! < – Krass! Irgendwas hat meine Rechte zusammengeschossen!!

Nunja, Gott sei Dank kann man das schnell beheben, indem man folgendes ins Terminal eintippt: `chmod 755 PLATTE

Jetzt fährt er wieder normal hoch… Puuuuhhh… Sachen gibt’s… ….die gibt’s doch sonst nur unter Windows… Naja, unter Windoof wäre die Daemon-Datei bestimmt tatsächlich gelöscht worden… :)

PS: wenn ihr keinen zweiten Mac habt, dann funktioniert auch folgendes: Startet den kaputten Mac, wobei ihr die APFEL und S Taste gedrückt haltet. So fährt der Mac im sogenannten SingleUser-Modus hoch. Ist der Rechner oben, könnt ihr ein Terminalfenster öffnen und dort folgendes eintippen:

`mount -uw / chmod 755 /`

Nach einem Neustart sollte jetzt wieder alles funktionieren.